Installation bundle synfony

J’essaye d’installer le bundle knp-paginator pour faire de la pagination. J’avais deja essayé d’installer d’autres bundles type FosUserBundle, DoctrineFixtureBundle mais je me heurte souvent au meme type d’erreur lors de l’installation de ces bundles.

Exemple pour l’installation du bundle knp-paginator:

J’ai rajouté dans mon fichier composer.json la ligne:
“knplabs: knplabs/knp-paginator_bundle”:“dev-master”

Puis j’ai lancé la commande sous dos: composer update

trace obtenue avec l’erreur:
Loadind composer repositories with package information
Updating depedencies

Problem 1

  • The requested package knplabs: knplabs/knp-paginato-bundle could not be found, it lokks like its name
    invalid, ‘:’ is not allowed in package names

Potentiel causes:

  • A typo in the packagename
  • The package is not available in a stable-enough version according to youtr minimum-stability setting

Est ce quelq’un à une idée pour résoudre ceci?

La réponse est dans le message d’erreur … tu as écris “knp-paginato”

Préfère les composer require aussi plutôt que d’aller directement écrire dans le JSON … plus rapide, plus fiable.